What’s Vulnerable › Vulnerabilities
CVE-2022-46171: Tauri vulnerable to path traversal
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-23 · updated 2026-06-17
- Weakness: CWE-22
Description
Tauri is a framework for building binaries for all major desktop platforms. The filesystem glob pattern wildcards `*`, `?`, and `[...]` match file path literals and leading dots by default, which unintentionally exposes sub folder content of allowed paths. Scopes without the wildcards are not affected. As `**` allows for sub directories the behavior there is also as expected. The issue has been patched in the latest release and was backported into the currently supported 1.x branches. There are no known workarounds at the time of publication.
Affected products
- tauri-apps tauri: from 1.0.0 before 1.0.8; from 1.1.0 before 1.1.3; from 1.2.0 before 1.2.3; 2.0.0-alpha0, 2.0.0-alpha1 — fixed in 1.0.8, 1.1.3, 1.2.3
How to fix
Upgrade to a fixed version: tauri-apps tauri 1.0.8, 1.1.3, 1.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/tauri-apps/tauri/commit/72389b00d7b495ffd7750eb1e75a3b8537d07cf3
- https://github.com/tauri-apps/tauri/commit/f0602e7c294245ab6ef6fbf2a976ef398340ef58
- https://github.com/tauri-apps/tauri/security/advisories/GHSA-6mv3-wm7j-h4w5
- https://github.com/tauri-apps/tauri/commit/72389b00d7b495ffd7750eb1e75a3b8537d07cf3
- https://github.com/tauri-apps/tauri/commit/f0602e7c294245ab6ef6fbf2a976ef398340ef58
- https://github.com/tauri-apps/tauri/security/advisories/GHSA-6mv3-wm7j-h4w5
Get alerted when CVE-2022-46171 or the next vulnerability affects your stack