What’s Vulnerable › Vulnerabilities
CVE-2022-46172: authentik allows existing authenticated users to create arbitrary accounts
- Severity: medium (CVSS 6.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-28 · updated 2026-06-17
- Weakness: CWE-269
Description
authentik is an open-source Identity provider focused on flexibility and versatility. In versions prior to 2022.10.4, and 2022.11.4, any authenticated user can create an arbitrary number of accounts through the default flows. This would circumvent any policy in a situation where it is undesirable for users to create new accounts by themselves. This may also affect other applications as these new basic accounts would exist throughout the SSO infrastructure. By default the newly created accounts cannot be logged into as no password reset exists by default. However password resets are likely to be enabled by most installations. This vulnerability pertains to the user context used in the default-user-settings-flow, /api/v3/flows/instances/default-user-settings-flow/execute/. This issue has been fixed in versions 2022.10.4 and 2022.11.4.
Affected products
- goauthentik authentik: from 2022.10.0 before 2022.10.4; from 2022.11.0 before 2022.11.4 — fixed in 2022.10.4, 2022.11.4
How to fix
Upgrade to a fixed version: goauthentik authentik 2022.10.4, 2022.11.4. Check the vendor advisory for mitigations.
References
- https://github.com/goauthentik/authentik/security/advisories/GHSA-hv8r-6w7p-mpc5
- https://github.com/goauthentik/authentik/security/advisories/GHSA-hv8r-6w7p-mpc5
Get alerted when CVE-2022-46172 or the next vulnerability affects your stack