What’s Vulnerable › Vulnerabilities
CVE-2022-46180: Arbitrary HTML injection in discourse-mermaid-theme-component
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-04 · updated 2026-06-17
- Weakness: CWE-74
Description
Discourse Mermaid (discourse-mermaid-theme-component) allows users of Discourse, open-source forum software, to create graphs using the Mermaid syntax. Users of discourse-mermaid-theme-component version 1.0.0 who can create posts are able to inject arbitrary HTML on that post. The issue has been fixed on the `main` branch of the GitHub repository, with 1.1.0 named as a patched version. Admins can update the theme component through the admin UI. As a workaround, admins can temporarily disable discourse-mermaid-theme-component.
Affected products
- discourse-mermaid-theme-component: from 1.0.0 before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: discourse-mermaid-theme-component 1.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse-mermaid-theme-component/commit/c10bc4a08bf865cee20e5d5dffba535762813f0f
- https://github.com/discourse/discourse-mermaid-theme-component/pull/14
- https://github.com/discourse/discourse-mermaid-theme-component/security/advisories/GHSA-8437-hgcm-p3q3
- https://github.com/discourse/discourse-mermaid-theme-component/commit/c10bc4a08bf865cee20e5d5dffba535762813f0f
- https://github.com/discourse/discourse-mermaid-theme-component/pull/14
- https://github.com/discourse/discourse-mermaid-theme-component/security/advisories/GHSA-8437-hgcm-p3q3
Get alerted when CVE-2022-46180 or the next vulnerability affects your stack