What’s Vulnerable › Vulnerabilities
CVE-2022-4623: ND Shortcodes < 7.0 - Contributor+ Stored XSS via Shortcodes
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-04 · updated 2026-06-17
Description
The ND Shortcodes WordPress plugin before 7.0 does not validate and escape numerous of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- ND Shortcodes: before 7.0 — fixed in 7.0
How to fix
Upgrade to a fixed version: ND Shortcodes 7.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1b3201da-f254-406f-9b4a-cd5025b6b03d
- https://wpscan.com/vulnerability/1b3201da-f254-406f-9b4a-cd5025b6b03d
Get alerted when CVE-2022-4623 or the next vulnerability affects your stack