What’s Vulnerable › Vulnerabilities

CVE-2022-46258: Incorrect Authorization in GitHub Enterprise Server leads to Action Workflow modifications without Workflow Scope

Description

An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed a repository-scoped token with read/write access to modify Action Workflow files without a Workflow scope. The Create or Update file contents API should enforce workflow scope. This vulnerability affected all versions of GitHub Enterprise Server prior to version 3.7 and was fixed in versions 3.3.16, 3.4.11, 3.5.8, and 3.6.4. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.3.16, 3.4.11, 3.5.8, 3.6.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-46258 or the next vulnerability affects your stack