What’s Vulnerable › Vulnerabilities
CVE-2022-4628: Easy PayPal Buy Now Button < 1.7.4 - Contributor+ Stored XSS in Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
Description
The Easy PayPal Buy Now Button WordPress plugin before 1.7.4 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- Easy PayPal Buy Now Button: before 1.7.4 — fixed in 1.7.4
How to fix
Upgrade to a fixed version: Easy PayPal Buy Now Button 1.7.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6ae719da-c43c-4b3a-bb8a-efa1de20100a
- https://wpscan.com/vulnerability/6ae719da-c43c-4b3a-bb8a-efa1de20100a
Get alerted when CVE-2022-4628 or the next vulnerability affects your stack