What’s Vulnerable › Vulnerabilities
CVE-2022-4629: Product Slider for WooCommerce < 2.6.4 - Contributor+ Stored XSS in Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Product Slider for WooCommerce WordPress plugin before 2.6.4 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Product Slider for WooCommerce: before 2.6.4 — fixed in 2.6.4
How to fix
Upgrade to a fixed version: Product Slider for WooCommerce 2.6.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/cf0a51f9-21d3-4ae8-b7d2-361921038fe8
- https://wpscan.com/vulnerability/cf0a51f9-21d3-4ae8-b7d2-361921038fe8
Get alerted when CVE-2022-4629 or the next vulnerability affects your stack