What’s Vulnerable › Vulnerabilities
CVE-2022-46337: Apache Derby: LDAP injection vulnerability in authenticator
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-20 · updated 2026-06-17
- Weakness: CWE-74
Description
A cleverly devised username might bypass LDAP authentication checks. In LDAP-authenticated Derby installations, this could let an attacker fill up the disk by creating junk Derby databases. In LDAP-authenticated Derby installations, this could also allow the attacker to execute malware which was visible to and executable by the account which booted the Derby server. In LDAP-protected databases which weren't also protected by SQL GRANT/REVOKE authorization, this vulnerability could also let an attacker view and corrupt sensitive data and run sensitive database functions and procedures. Mitigation: Users should upgrade to Java 21 and Derby 10.17.1.0. Alternatively, users who wish to remain on older Java versions should build their own Derby distribution from one of the release families to which the fix was backported: 10.16, 10.15, and 10.14. Those are the releases which correspond, respectively, with Java LTS versions 17, 11, and 8.
Affected products
- Apache Software Foundation Apache Derby: from 10.1.1.0 before 10.14.3.0; from 10.15.1.3 before 10.15.2.1; 10.16.1.1 — fixed in 10.14.3.0, 10.15.2.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Derby 10.14.3.0, 10.15.2.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/q23kvvtoohgzwybxpwozmvvk17rp0td3
- https://lists.apache.org/thread/q23kvvtoohgzwybxpwozmvvk17rp0td3
Get alerted when CVE-2022-46337 or the next vulnerability affects your stack