What’s Vulnerable › Vulnerabilities
CVE-2022-4634: CVE-2022-4634
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-03 · updated 2026-06-17
- Weakness: CWE-121
Description
All versions prior to Delta Electronic’s CNCSoft version 1.01.34 (running ScreenEditor versions 1.01.5 and prior) are vulnerable to a stack-based buffer overflow, which could allow an attacker to remotely execute arbitrary code.
Affected products
- Delta Electronics CNCSoft: before 1.01.34 — fixed in 1.01.34
- Delta Industrial Automation ScreenEditor: before 1.01.5 — fixed in 1.01.5
How to fix
Upgrade to a fixed version: Delta Electronics CNCSoft 1.01.34; Delta Industrial Automation ScreenEditor 1.01.5. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-23-026-01
- https://www.cisa.gov/uscert/ics/advisories/icsa-23-026-01
Get alerted when CVE-2022-4634 or the next vulnerability affects your stack