What’s Vulnerable › Vulnerabilities
CVE-2022-46366: Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-02 · updated 2026-06-17
- Weakness: CWE-502
Description
Apache Tapestry 3.x allows deserialization of untrusted data, leading to remote code execution. This issue is similar to but distinct from CVE-2020-17531, which applies the the (also unsupported) 4.x version line. NOTE: This vulnerability only affects Apache Tapestry version line 3.x, which is no longer supported by the maintainer. Users are recommended to upgrade to a supported version line of Apache Tapestry.
Affected products
- Apache Software Foundation Apache Tapestry: from 3.0.0 before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Tapestry 4.0.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/12/02/1
- https://github.com/mandiant/Vulnerability-Disclosures/blob/master/2022/MNDT-2022-0041/MNDT-2022-0041.md
- https://lists.apache.org/thread/bwn1vjrvz1hq0wbdzj23wz322244swhj
- http://www.openwall.com/lists/oss-security/2022/12/02/1
- https://github.com/mandiant/Vulnerability-Disclosures/blob/master/2022/MNDT-2022-0041/MNDT-2022-0041.md
- https://lists.apache.org/thread/bwn1vjrvz1hq0wbdzj23wz322244swhj
Get alerted when CVE-2022-46366 or the next vulnerability affects your stack