What’s Vulnerable › Vulnerabilities
CVE-2022-4638: collective.contact.widget widgets.py title cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-21 · updated 2026-06-17
- Weakness: CWE-707
Description
A vulnerability classified as problematic was found in collective.contact.widget up to 1.12. This vulnerability affects the function title of the file src/collective/contact/widget/widgets.py. The manipulation leads to cross site scripting. The attack can be initiated remotely. The name of the patch is 5da36305ca7ed433782be8901c47387406fcda12. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-216496.
Affected products
- collective.contact.widget: before 1.12 — fixed in 1.12
How to fix
Upgrade to a fixed version: collective.contact.widget 1.12. Check the vendor advisory for mitigations.
References
- https://github.com/collective/collective.contact.widget/commit/5da36305ca7ed433782be8901c47387406fcda12
- https://vuldb.com/?id.216496
- https://github.com/collective/collective.contact.widget/commit/5da36305ca7ed433782be8901c47387406fcda12
- https://vuldb.com/?id.216496
Get alerted when CVE-2022-4638 or the next vulnerability affects your stack