What’s Vulnerable › Vulnerabilities
CVE-2022-46387
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-28 · updated 2026-06-17
- Weakness: CWE-116
Description
ConEmu through 220807 and Cmder before 1.3.21 report the title of the terminal, including control characters, which allows an attacker to change the title and then execute it as commands.
Affected products
- Cmder: before 1.3.2 — fixed in 1.3.2
- Maximus5 Conemu: through 22.08.07
How to fix
Upgrade to a fixed version: Cmder 1.3.2. Check the vendor advisory for mitigations.
References
- https://gist.github.com/dgl/05ca60cdc7efc9e47bbc58d0c952635e
- https://github.com/cmderdev/cmder/blob/master/CHANGELOG.md
- https://gist.github.com/dgl/05ca60cdc7efc9e47bbc58d0c952635e
- https://github.com/cmderdev/cmder/blob/master/CHANGELOG.md
Get alerted when CVE-2022-46387 or the next vulnerability affects your stack