What’s Vulnerable › Vulnerabilities
CVE-2022-46421: Apache Airflow Hive Provider: Hive Provider RCE vulnerability with hive_cli_params
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-20 · updated 2026-06-17
- Weakness: CWE-77
Description
Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow Hive Provider.This issue affects Apache Airflow Hive Provider: before 5.0.0.
Affected products
- Apache Software Foundation Apache Airflow Hive Provider: before 5.0.0 — fixed in 5.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow Hive Provider 5.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/28101
- https://lists.apache.org/thread/09twdoyoybldlfj5gvk0qswtofh0rmp4
- https://github.com/apache/airflow/pull/28101
- https://lists.apache.org/thread/09twdoyoybldlfj5gvk0qswtofh0rmp4
Get alerted when CVE-2022-46421 or the next vulnerability affects your stack