What’s Vulnerable › Vulnerabilities
CVE-2022-4643: docconv pdf_ocr.go ConvertPDFImages os command injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-21 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability was found in docconv up to 1.2.0. It has been declared as critical. This vulnerability affects the function ConvertPDFImages of the file pdf_ocr.go. The manipulation of the argument path leads to os command injection. The attack can be initiated remotely. Upgrading to version 1.2.1 is able to address this issue. The name of the patch is b19021ade3d0b71c89d35cb00eb9e589a121faa5. It is recommended to upgrade the affected component. VDB-216502 is the identifier assigned to this vulnerability.
Affected products
- docconv: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: docconv 1.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/sajari/docconv/commit/b19021ade3d0b71c89d35cb00eb9e589a121faa5
- https://github.com/sajari/docconv/pull/110
- https://github.com/sajari/docconv/releases/tag/v1.2.1
- https://vuldb.com/?id.216502
- https://github.com/sajari/docconv/commit/b19021ade3d0b71c89d35cb00eb9e589a121faa5
- https://github.com/sajari/docconv/pull/110
- https://github.com/sajari/docconv/releases/tag/v1.2.1
- https://vuldb.com/?id.216502
Get alerted when CVE-2022-4643 or the next vulnerability affects your stack