What’s Vulnerable › Vulnerabilities
CVE-2022-4649: WP Extended Search < 2.1.2 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The WP Extended Search WordPress plugin before 2.1.2 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Affected products
- WP Extended Search: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: WP Extended Search 2.1.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0d9ba176-97be-4b6b-9cf1-6c3047321a1e
- https://wpscan.com/vulnerability/0d9ba176-97be-4b6b-9cf1-6c3047321a1e
Get alerted when CVE-2022-4649 or the next vulnerability affects your stack