What’s Vulnerable › Vulnerabilities
CVE-2022-4650: HashBar – WordPress Notification Bar < 1.3.6 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
- Weakness: CWE-79
Description
The HashBar WordPress plugin before 1.3.6 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Affected products
- HashBar: before 1.3.6 — fixed in 1.3.6
How to fix
Upgrade to a fixed version: HashBar 1.3.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b430fdaa-191a-429e-b6d2-479b32bb1075
- https://wpscan.com/vulnerability/b430fdaa-191a-429e-b6d2-479b32bb1075
Get alerted when CVE-2022-4650 or the next vulnerability affects your stack