What’s Vulnerable › Vulnerabilities
CVE-2022-4652: Video Background < 2.7.5 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-13 · updated 2026-06-17
Description
The Video Background WordPress plugin before 2.7.5 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- Video Background: before 2.7.5 — fixed in 2.7.5
How to fix
Upgrade to a fixed version: Video Background 2.7.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ebf3df99-6939-4ae9-ad55-004f33c1cfbc
- https://wpscan.com/vulnerability/ebf3df99-6939-4ae9-ad55-004f33c1cfbc
Get alerted when CVE-2022-4652 or the next vulnerability affects your stack