What’s Vulnerable › Vulnerabilities
CVE-2022-4654: Pricing Tables WordPress Plugin – Easy Pricing Tables < 3.2.3 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The Pricing Tables WordPress Plugin WordPress plugin before 3.2.3 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Affected products
- Pricing Tables WordPress Plugin: before 3.2.3 — fixed in 3.2.3
How to fix
Upgrade to a fixed version: Pricing Tables WordPress Plugin 3.2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a29744cd-b760-4757-8564-883d59fa4881
- https://wpscan.com/vulnerability/a29744cd-b760-4757-8564-883d59fa4881
Get alerted when CVE-2022-4654 or the next vulnerability affects your stack