What’s Vulnerable › Vulnerabilities
CVE-2022-4655: Welcart e-Commerce < 2.8.9 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The Welcart e-Commerce WordPress plugin before 2.8.9 does not validate and escapes one of its shortcode attributes, which could allow users with a role as low as a contributor to perform a Stored Cross-Site Scripting attack.
Affected products
- Welcart e-Commerce: before 2.8.9 — fixed in 2.8.9
How to fix
Upgrade to a fixed version: Welcart e-Commerce 2.8.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a1c70c80-e952-4cc7-aca0-c2dde3fa08a9
- https://wpscan.com/vulnerability/a1c70c80-e952-4cc7-aca0-c2dde3fa08a9
Get alerted when CVE-2022-4655 or the next vulnerability affects your stack