What’s Vulnerable › Vulnerabilities
CVE-2022-4657: Restaurant Menu < 2.3.6 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The Restaurant Menu WordPress plugin before 2.3.6 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- gloriafood Restaurant Menu – Food Ordering System – Table Reservation: before 2.3.6 — fixed in 2.3.6
How to fix
Upgrade to a fixed version: gloriafood Restaurant Menu – Food Ordering System – Table Reservation 2.3.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a90a413d-0e00-4da8-a339-d6cdfba70bb3
- https://wpscan.com/vulnerability/a90a413d-0e00-4da8-a339-d6cdfba70bb3
Get alerted when CVE-2022-4657 or the next vulnerability affects your stack