What’s Vulnerable › Vulnerabilities
CVE-2022-4661: Woo Products Widgets For Elementor < 1.0.8 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Widgets for WooCommerce Products on Elementor WordPress plugin before 1.0.8 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- Widgets for WooCommerce Products on Elementor: before 1.0.8 — fixed in 1.0.8
How to fix
Upgrade to a fixed version: Widgets for WooCommerce Products on Elementor 1.0.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/b95956c9-40e5-47aa-86f6-e2da61b3c19f
- https://wpscan.com/vulnerability/b95956c9-40e5-47aa-86f6-e2da61b3c19f
Get alerted when CVE-2022-4661 or the next vulnerability affects your stack