What’s Vulnerable › Vulnerabilities
CVE-2022-46651: Apache Airflow: Security vulnerability on AirFlow Connections
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-12 · updated 2026-06-17
- Weakness: CWE-200
Description
Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows an unauthorized actor to gain access to sensitive information in Connection edit view. This vulnerability is considered low since it requires someone with access to Connection resources specifically updating the connection to exploit it. Users should upgrade to version 2.6.3 or later which has removed the vulnerability.
Affected products
- Apache Airflow: before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: Apache Airflow 2.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/32309
- https://lists.apache.org/thread/n45h3y82og125rnlgt6rbm9szfb6q24d
- https://github.com/apache/airflow/pull/32309
- https://lists.apache.org/thread/n45h3y82og125rnlgt6rbm9szfb6q24d
Get alerted when CVE-2022-46651 or the next vulnerability affects your stack