What’s Vulnerable › Vulnerabilities
CVE-2022-46658: CVE-2022-46658
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-22 · updated 2026-06-17
Description
The affected product is vulnerable to a stack-based buffer overflow which could lead to a denial of service or remote code execution.
Affected products
- Dataprobe Iboot-Pdu4-C20 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu4-N20 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu4A-C10 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu4A-C20 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu4A-N15 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu4A-N20 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu4Sa-C10 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu4Sa-C20 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu4Sa-N15 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu4Sa-N20 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu8A-2C10 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu8A-2C20 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu8A-2N15 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu8A-2N20 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu8A-C10 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu8A-C20 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu8A-N15 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu8A-N20 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu8Sa-2N15 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu8Sa-C10 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu8Sa-N15 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
- Dataprobe Iboot-Pdu8Sa-N20 Firmware: before 1.42.06162022 — fixed in 1.42.06162022
How to fix
Upgrade to a fixed version: Dataprobe Iboot-Pdu4-C20 Firmware 1.42.06162022; Dataprobe Iboot-Pdu4-N20 Firmware 1.42.06162022; Dataprobe Iboot-Pdu4A-C10 Firmware 1.42.06162022; Dataprobe Iboot-Pdu4A-C20 Firmware 1.42.06162022; Dataprobe Iboot-Pdu4A-N15 Firmware 1.42.06162022; Dataprobe Iboot-Pdu4A-N20 Firmware 1.42.06162022; Dataprobe Iboot-Pdu4Sa-C10 Firmware 1.42.06162022; Dataprobe Iboot-Pdu4Sa-C20 Firmware 1.42.06162022; Dataprobe Iboot-Pdu4Sa-N15 Firmware 1.42.06162022; Dataprobe Iboot-Pdu4Sa-N20 Firmware 1.42.06162022; Dataprobe Iboot-Pdu8A-2C10 Firmware 1.42.06162022; Dataprobe Iboot-Pdu8A-2C20 Firmware 1.42.06162022. Check the vendor advisory for mitigations.
References
- https://dataprobe.com/support/iboot-pdu/local_upgrade_pdu_procedure.pdf
- https://www.cisa.gov/news-events/ics-advisories/icsa-22-263-03
- https://dataprobe.com/support/iboot-pdu/local_upgrade_pdu_procedure.pdf
- https://www.cisa.gov/news-events/ics-advisories/icsa-22-263-03
Get alerted when CVE-2022-46658 or the next vulnerability affects your stack