What’s Vulnerable › Vulnerabilities
CVE-2022-4667: RSS Aggregator by Feedzy < 4.1.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
The RSS Aggregator by Feedzy WordPress plugin before 4.1.1 does not validate and escape some of its block options before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- themeisle RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator: before 4.1.1 — fixed in 4.1.1
How to fix
Upgrade to a fixed version: themeisle RSS Aggregator by Feedzy – Feed to Post, Autoblogging, News & YouTube Video Feeds Aggregator 4.1.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/a388232b-a399-46a5-83e6-20c1b5df351d
- https://wpscan.com/vulnerability/a388232b-a399-46a5-83e6-20c1b5df351d
Get alerted when CVE-2022-4667 or the next vulnerability affects your stack