What’s Vulnerable › Vulnerabilities
CVE-2022-4668: Easy Appointments < 3.11.2 - Contributor+ Stored XSS in Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Easy Appointments WordPress plugin before 3.11.2 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- Easy Appointments: before 3.11.2 — fixed in 3.11.2
How to fix
Upgrade to a fixed version: Easy Appointments 3.11.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/3e43156a-b784-4066-be69-23b139aafbad
- https://wpscan.com/vulnerability/3e43156a-b784-4066-be69-23b139aafbad
Get alerted when CVE-2022-4668 or the next vulnerability affects your stack