What’s Vulnerable › Vulnerabilities
CVE-2022-46684
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-12 · updated 2026-06-17
- Weakness: CWE-79
Description
Jenkins Checkmarx Plugin 2022.3.3 and earlier does not escape values returned from the Checkmarx service API before inserting them into HTML reports, resulting in a stored cross-site scripting (XSS) vulnerability.
Affected products
- Jenkins Project Jenkins Checkmarx Plugin: before 2022.4.3 — fixed in 2022.4.3
How to fix
Upgrade to a fixed version: Jenkins Project Jenkins Checkmarx Plugin 2022.4.3. Check the vendor advisory for mitigations.
References
- https://www.jenkins.io/security/advisory/2022-12-07/#SECURITY-2869
- https://www.jenkins.io/security/advisory/2022-12-07/#SECURITY-2869
Get alerted when CVE-2022-46684 or the next vulnerability affects your stack