What’s Vulnerable › Vulnerabilities
CVE-2022-4669: Page Builder: Live Composer < 1.5.23 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-21 · updated 2026-06-17
- Weakness: CWE-79
Description
The Page Builder: Live Composer WordPress plugin before 1.5.23 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- Live Composer Team Page Builder: Live Composer: before 1.5.23 — fixed in 1.5.23
How to fix
Upgrade to a fixed version: Live Composer Team Page Builder: Live Composer 1.5.23. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/79f011e4-3422-4307-8736-f27048796aae
- https://wpscan.com/vulnerability/79f011e4-3422-4307-8736-f27048796aae
Get alerted when CVE-2022-4669 or the next vulnerability affects your stack