What’s Vulnerable › Vulnerabilities
CVE-2022-4670: PDF.js Viewer < 2.1.8 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The PDF.js Viewer WordPress plugin before 2.1.8 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- PDF.js Viewer: before 2.1.8 — fixed in 2.1.8
How to fix
Upgrade to a fixed version: PDF.js Viewer 2.1.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/2a67c290-2a27-44fe-95ae-2d427e9d7548
- https://wpscan.com/vulnerability/2a67c290-2a27-44fe-95ae-2d427e9d7548
Get alerted when CVE-2022-4670 or the next vulnerability affects your stack