What’s Vulnerable › Vulnerabilities
CVE-2022-4671: PixCodes < 2.3.7 - Contributor+ Stored XSS in Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The PixCodes WordPress plugin before 2.3.7 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
Affected products
- PixCodes: before 2.3.7 — fixed in 2.3.7
How to fix
Upgrade to a fixed version: PixCodes 2.3.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/14c83830-3207-4f92-b8f5-afd7cc93af88
- https://wpscan.com/vulnerability/14c83830-3207-4f92-b8f5-afd7cc93af88
Get alerted when CVE-2022-4671 or the next vulnerability affects your stack