What’s Vulnerable › Vulnerabilities
CVE-2022-4673: Rate my Post – WP Rating System < 3.3.9 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Rate my Post WordPress plugin before 3.3.9 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Affected products
- FeedbackWP Rate my Post – WP Rating System: before 3.3.9 — fixed in 3.3.9
How to fix
Upgrade to a fixed version: FeedbackWP Rate my Post – WP Rating System 3.3.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/1c4f379d-252a-487b-81c9-bf711ab71dff
- https://wpscan.com/vulnerability/1c4f379d-252a-487b-81c9-bf711ab71dff
Get alerted when CVE-2022-4673 or the next vulnerability affects your stack