What’s Vulnerable › Vulnerabilities
CVE-2022-46741
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-07 · updated 2026-06-17
- Weakness: CWE-125
Description
Out-of-bounds read in gather_tree in PaddlePaddle before 2.4.
Affected products
- paddlepaddle/paddle: before 2.4 — fixed in 2.4
How to fix
Upgrade to a fixed version: paddlepaddle/paddle 2.4. Check the vendor advisory for mitigations.
References
- https://github.com/PaddlePaddle/Paddle/blob/develop/security/advisory/pdsa-2022-001.md
- https://github.com/PaddlePaddle/Paddle/blob/develop/security/advisory/pdsa-2022-001.md
Get alerted when CVE-2022-46741 or the next vulnerability affects your stack