What’s Vulnerable › Vulnerabilities
CVE-2022-4675: Mongoose Page Plugin < 1.9.0 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-23 · updated 2026-06-17
Description
The Mongoose Page Plugin WordPress plugin before 1.9.0 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Affected products
- Mongoose Page Plugin: before 1.9.0 — fixed in 1.9.0
How to fix
Upgrade to a fixed version: Mongoose Page Plugin 1.9.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/21f4cc5d-c4b4-495f-acf3-9fdf53591052
- https://wpscan.com/vulnerability/21f4cc5d-c4b4-495f-acf3-9fdf53591052
Get alerted when CVE-2022-4675 or the next vulnerability affects your stack