What’s Vulnerable › Vulnerabilities
CVE-2022-4677: Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) < 3.12.7 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-06 · updated 2026-06-17
Description
The Leaflet Maps Marker WordPress plugin before 3.12.7 does not validate and escape one of its shortcode attributes, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attack.
Affected products
- Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps): before 3.12.7 — fixed in 3.12.7
How to fix
Upgrade to a fixed version: Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps) 3.12.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/9c293098-de54-4a04-b13d-2a702200f02e
- https://wpscan.com/vulnerability/9c293098-de54-4a04-b13d-2a702200f02e
Get alerted when CVE-2022-4677 or the next vulnerability affects your stack