What’s Vulnerable › Vulnerabilities
CVE-2022-4678: TemplatesNext ToolKit < 3.2.8 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
Description
The TemplatesNext ToolKit WordPress plugin before 3.2.8 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.
Affected products
- TemplatesNext ToolKit: before 3.2.8 — fixed in 3.2.8
How to fix
Upgrade to a fixed version: TemplatesNext ToolKit 3.2.8. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6a36d665-a0ca-4346-8e55-cf9ba45966cc
- https://wpscan.com/vulnerability/6a36d665-a0ca-4346-8e55-cf9ba45966cc
Get alerted when CVE-2022-4678 or the next vulnerability affects your stack