What’s Vulnerable › Vulnerabilities
CVE-2022-4679: Wufoo Shortcode < 1.52 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-27 · updated 2026-06-17
Description
The Wufoo Shortcode WordPress plugin before 1.52 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- Wufoo Shortcode: before 1.52 — fixed in 1.52
How to fix
Upgrade to a fixed version: Wufoo Shortcode 1.52. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c817c4af-cff2-4720-944d-c59e27544d41
- https://wpscan.com/vulnerability/c817c4af-cff2-4720-944d-c59e27544d41
Get alerted when CVE-2022-4679 or the next vulnerability affects your stack