What’s Vulnerable › Vulnerabilities

CVE-2022-46792

Description

Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many API for Postgres backends. The fixed versions are 2.10.2, 2.11.3, 2.12.1, 2.13.2, 2.14.1, and 2.15.2. (Versions before 2.10.0 are unaffected.)

Affected products

How to fix

Upgrade to a fixed version: Hasura GraphQL 2.10.2, 2.11.3, 2.13.2, 2.15.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-46792 or the next vulnerability affects your stack