What’s Vulnerable › Vulnerabilities
CVE-2022-4680: Revive Old Posts – Social Media Auto Post and Scheduling Plugin < 9.0.11 - PHP Object Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-30 · updated 2026-06-17
Description
The Revive Old Posts WordPress plugin before 9.0.11 unserializes user input provided via the settings, which could allow high privilege users such as admin to perform PHP Object Injection when a suitable gadget is present.
Affected products
- Revive Old Posts: before 9.0.11 — fixed in 9.0.11
How to fix
Upgrade to a fixed version: Revive Old Posts 9.0.11. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/f4197386-975d-4e53-8fc9-9425732da9af
- https://wpscan.com/vulnerability/f4197386-975d-4e53-8fc9-9425732da9af
Get alerted when CVE-2022-4680 or the next vulnerability affects your stack