What’s Vulnerable › Vulnerabilities
CVE-2022-4682: Lightbox Gallery < 0.9.5 - Contributor+ Stored XSS via Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-02-13 · updated 2026-06-17
Description
The Lightbox Gallery WordPress plugin before 0.9.5 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks
Affected products
- Lightbox Gallery: before 0.9.5 — fixed in 0.9.5
How to fix
Upgrade to a fixed version: Lightbox Gallery 0.9.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5fc92954-20cf-4563-806e-e7a8e5ccfc72
- https://wpscan.com/vulnerability/5fc92954-20cf-4563-806e-e7a8e5ccfc72
Get alerted when CVE-2022-4682 or the next vulnerability affects your stack