What’s Vulnerable › Vulnerabilities
CVE-2022-46823
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-10 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability has been identified in Mendix SAML (Mendix 8 compatible) (All versions >= V2.3.0 < V2.3.4), Mendix SAML (Mendix 9 compatible, New Track) (All versions >= V3.3.0 < V3.3.9), Mendix SAML (Mendix 9 compatible, Upgrade Track) (All versions >= V3.3.0 < V3.3.8). The affected module is vulnerable to reflected cross-site scripting (XSS) attacks. This could allow an attacker to extract sensitive information by tricking users into accessing a malicious link.
Affected products
- Siemens Mendix SAML Module: from 2.3.0 before 2.3.4; from 3.3.0 before 3.3.9 — fixed in 2.3.4, 3.3.9
How to fix
Upgrade to a fixed version: Siemens Mendix SAML Module 2.3.4, 3.3.9. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-496604.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-496604.pdf
Get alerted when CVE-2022-46823 or the next vulnerability affects your stack