What’s Vulnerable › Vulnerabilities
CVE-2022-46870: Apache Zeppelin: Stored XSS in note permissions
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-16 · updated 2026-06-17
- Weakness: CWE-79
Description
An Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Zeppelin allows logged-in users to execute arbitrary javascript in other users' browsers. This issue affects Apache Zeppelin before 0.8.2. Users are recommended to upgrade to a supported version of Zeppelin.
Affected products
- Apache Software Foundation Apache Zeppelin: before 0.8.2 — fixed in 0.8.2
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.8.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/gb1wdnrm1095xw6qznpsycfrht4lwbwc
- https://lists.apache.org/thread/gb1wdnrm1095xw6qznpsycfrht4lwbwc
Get alerted when CVE-2022-46870 or the next vulnerability affects your stack