What’s Vulnerable › Vulnerabilities
CVE-2022-46873
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-74
Description
Because Firefox did not implement the <code>unsafe-hashes</code> CSP directive, an attacker who was able to inject markup into a page otherwise protected by a Content Security Policy may have been able to inject executable script. This would be severely constrained by the specified Content Security Policy of the document. This vulnerability affects Firefox < 108.
Affected products
- Mozilla Firefox: before 108.0 — fixed in 108.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 108.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1644790
- https://security.gentoo.org/glsa/202305-06
- https://www.mozilla.org/security/advisories/mfsa2022-51/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1644790
- https://security.gentoo.org/glsa/202305-06
- https://www.mozilla.org/security/advisories/mfsa2022-51/
Get alerted when CVE-2022-46873 or the next vulnerability affects your stack