What’s Vulnerable › Vulnerabilities
CVE-2022-4688: Improper Authorization in usememos/memos
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-23 · updated 2026-06-17
- Weakness: CWE-285
Description
Improper Authorization in GitHub repository usememos/memos prior to 0.9.0.
Affected products
- usememos/memos: before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: usememos/memos 0.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/usememos/memos/commit/dca35bde877aab6e64ef51b52e590b5d48f692f9
- https://huntr.dev/bounties/23856e7e-94ff-4dee-97d0-0cd47e9b8ff6
- https://github.com/usememos/memos/commit/dca35bde877aab6e64ef51b52e590b5d48f692f9
- https://huntr.dev/bounties/23856e7e-94ff-4dee-97d0-0cd47e9b8ff6
Get alerted when CVE-2022-4688 or the next vulnerability affects your stack