What’s Vulnerable › Vulnerabilities
CVE-2022-46887
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 19.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-19 · updated 2026-06-17
- Weakness: CWE-89
Description
Multiple SQL injection vulnerabilities in NexusPHP before 1.7.33 allow remote attackers to execute arbitrary SQL commands via the conuser[] parameter in takeconfirm.php; the delcheater parameter in cheaterbox.php; or the usernw parameter in nowarn.php.
Affected products
- Nexusphp: before 1.7.33 — fixed in 1.7.33
How to fix
Upgrade to a fixed version: Nexusphp 1.7.33. Check the vendor advisory for mitigations.
References
- https://github.com/xiaomlove/nexusphp/releases/tag/v1.7.33
- https://www.surecloud.com/resources/blog/nexusphp-surecloud-security-review-identifies-authenticated-unauthenticated-vulnerabilities
- https://github.com/xiaomlove/nexusphp/releases/tag/v1.7.33
- https://www.surecloud.com/resources/blog/nexusphp-surecloud-security-review-identifies-authenticated-unauthenticated-vulnerabilities
Get alerted when CVE-2022-46887 or the next vulnerability affects your stack