What’s Vulnerable › Vulnerabilities
CVE-2022-46888
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Multiple reflective cross-site scripting (XSS) vulnerabilities in NexusPHP before 1.7.33 allow remote attackers to inject arbitrary web script or HTML via the secret parameter in /login.php; q parameter in /user-ban-log.php; query parameter in /log.php; text parameter in /moresmiles.php; q parameter in myhr.php; or id parameter in /viewrequests.php.
Affected products
- Nexusphp: before 1.7.33 — fixed in 1.7.33
How to fix
Upgrade to a fixed version: Nexusphp 1.7.33. Check the vendor advisory for mitigations.
References
- https://github.com/xiaomlove/nexusphp/releases/tag/v1.7.33
- https://www.surecloud.com/resources/blog/nexusphp-surecloud-security-review-identifies-authenticated-unauthenticated-vulnerabilities
- https://github.com/xiaomlove/nexusphp/releases/tag/v1.7.33
- https://www.surecloud.com/resources/blog/nexusphp-surecloud-security-review-identifies-authenticated-unauthenticated-vulnerabilities
Get alerted when CVE-2022-46888 or the next vulnerability affects your stack