What’s Vulnerable › Vulnerabilities
CVE-2022-46889
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 60.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-19 · updated 2026-06-17
- Weakness: CWE-79
Description
A persistent cross-site scripting (XSS) vulnerability in NexusPHP before 1.7.33 allows remote authenticated attackers to permanently inject arbitrary web script or HTML via the title parameter used in /subtitles.php.
Affected products
- Nexusphp: before 1.7.33 — fixed in 1.7.33
How to fix
Upgrade to a fixed version: Nexusphp 1.7.33. Check the vendor advisory for mitigations.
References
- https://github.com/xiaomlove/nexusphp/releases/tag/v1.7.33
- https://www.surecloud.com/resources/blog/nexusphp-surecloud-security-review-identifies-authenticated-unauthenticated-vulnerabilities
- https://github.com/xiaomlove/nexusphp/releases/tag/v1.7.33
- https://www.surecloud.com/resources/blog/nexusphp-surecloud-security-review-identifies-authenticated-unauthenticated-vulnerabilities
Get alerted when CVE-2022-46889 or the next vulnerability affects your stack