What’s Vulnerable › Vulnerabilities
CVE-2022-46890
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-19 · updated 2026-06-17
- Weakness: CWE-284
Description
Weak access control in NexusPHP before 1.7.33 allows a remote authenticated user to edit any post in the forum (this is caused by a lack of checks performed by the /forums.php?action=post page).
Affected products
- Nexusphp: before 1.7.33 — fixed in 1.7.33
How to fix
Upgrade to a fixed version: Nexusphp 1.7.33. Check the vendor advisory for mitigations.
References
- https://github.com/xiaomlove/nexusphp/releases/tag/v1.7.33
- https://www.surecloud.com/resources/blog/nexusphp-surecloud-security-review-identifies-authenticated-unauthenticated-vulnerabilities
- https://github.com/xiaomlove/nexusphp/releases/tag/v1.7.33
- https://www.surecloud.com/resources/blog/nexusphp-surecloud-security-review-identifies-authenticated-unauthenticated-vulnerabilities
Get alerted when CVE-2022-46890 or the next vulnerability affects your stack