What’s Vulnerable › Vulnerabilities
CVE-2022-4690: Cross-site Scripting (XSS) - Stored in usememos/memos
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.0.
Affected products
- usememos/memos: before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: usememos/memos 0.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/usememos/memos/commit/c07b4a57caa89905e54b800f4d8fb720bbf5bf82
- https://huntr.dev/bounties/7e1be91d-3b13-4300-8af2-9bd9665ec335
- https://github.com/usememos/memos/commit/c07b4a57caa89905e54b800f4d8fb720bbf5bf82
- https://huntr.dev/bounties/7e1be91d-3b13-4300-8af2-9bd9665ec335
Get alerted when CVE-2022-4690 or the next vulnerability affects your stack