What’s Vulnerable › Vulnerabilities
CVE-2022-46907: Apache JSPWiki: XSS Injection points in several plugins
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-05-25 · updated 2026-06-17
- Weakness: CWE-79
Description
A carefully crafted request on several JSPWiki plugins could trigger an XSS vulnerability on Apache JSPWiki, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.12.0 or later.
Affected products
- Apache Software Foundation Apache JSPWiki: before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache JSPWiki 2.12.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/05/25/1
- https://lists.apache.org/thread/1m0mkq2nttx8tn94m11mytn4f0tv1504
- http://www.openwall.com/lists/oss-security/2023/05/25/1
- https://lists.apache.org/thread/1m0mkq2nttx8tn94m11mytn4f0tv1504
Get alerted when CVE-2022-46907 or the next vulnerability affects your stack