What’s Vulnerable › Vulnerabilities
CVE-2022-46908
- Severity: high (CVSS 7.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-12 · updated 2026-10-14
Description
SQLite through 3.40.0, when relying on --safe for execution of an untrusted CLI script, does not properly implement the azProhibitedFunctions protection mechanism, and instead allows UDF functions such as WRITEFILE.
Affected products
- SQLite: from 3.37.0 before 3.40.1 — fixed in 3.40.1
How to fix
Upgrade to a fixed version: SQLite 3.40.1. Check the vendor advisory for mitigations.
References
- https://news.ycombinator.com/item?id=33948588
- https://security.gentoo.org/glsa/202311-03
- https://security.netapp.com/advisory/ntap-20230203-0005/
- https://sqlite.org/forum/forumpost/07beac8056151b2f
- https://sqlite.org/src/info/cefc032473ac5ad2
- https://news.ycombinator.com/item?id=33948588
- https://security.gentoo.org/glsa/202311-03
- https://security.netapp.com/advisory/ntap-20230203-0005/
- https://sqlite.org/forum/forumpost/07beac8056151b2f
- https://sqlite.org/src/info/cefc032473ac5ad2
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://cert-portal.siemens.com/productcert/html/ssa-556635.html
Get alerted when CVE-2022-46908 or the next vulnerability affects your stack