What’s Vulnerable › Vulnerabilities
CVE-2022-4695: Cross-site Scripting (XSS) - Stored in usememos/memos
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.0.
Affected products
- usememos/memos: before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: usememos/memos 0.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/usememos/memos/commit/65cc19c12efa392f792f6bb154b4838547e0af5e
- https://huntr.dev/bounties/2559d548-b847-40fb-94d6-18c1ad58b789
- https://github.com/usememos/memos/commit/65cc19c12efa392f792f6bb154b4838547e0af5e
- https://huntr.dev/bounties/2559d548-b847-40fb-94d6-18c1ad58b789
Get alerted when CVE-2022-4695 or the next vulnerability affects your stack